Commit 41c5a363 authored by Howard Chu's avatar Howard Chu
Browse files

Require 2.1.3 or higher for Cyrus SASL 2

parent fbe4785c
......@@ -1183,3 +1183,16 @@ AC_DEFUN(OL_FUNC_GETHOSTBYADDR_R_NARGS,
fi
])dnl
dnl
dnl --------------------------------------------------------------------
dnl Check for Cyrus SASL version compatility, need 2.1.3 or newer
AC_DEFUN([OL_SASL2_COMPAT],
[AC_CACHE_CHECK([Cyrus SASL 2 library version], [ol_cv_sasl2_compat],[
AC_EGREP_CPP(__sasl2_version_compat,[
#include <sasl/sasl.h>
/* require 2.1.3 or later */
#if SASL_VERSION_MAJOR >= 2 && (SASL_VERSION_MINOR > 1 || SASL_VERSION_STEP > 2)
__sasl2_version_compat
#endif
], [ol_cv_sasl2_compat=yes], [ol_cv_sasl2_compat=no])])
])
......@@ -2169,6 +2169,14 @@ if test $ol_with_cyrus_sasl != no ; then
[ol_link_sasl="-lsasl"])])
fi
if test $ol_link_sasl = "-lsasl2"; then
OL_SASL2_COMPAT
if test $ol_cv_sasl2_compat = no ; then
ol_link_sasl=no
AC_MSG_ERROR(SASL: Cyrus SASL2 version obsolete)
fi
fi
if test $ol_link_sasl = no ; then
if test $ol_with_cyrus_sasl != auto ; then
AC_MSG_ERROR([Could not locate Cyrus SASL])
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment