Commit bb49be25 authored by Kurt Zeilenga's avatar Kurt Zeilenga
Browse files

Never publish:

supportedLDAPversion: 2
parent c83f7539
......@@ -176,14 +176,13 @@ root_dse_info(
}
/* supportedLDAPVersion */
for ( i=LDAP_VERSION_MIN; i<=LDAP_VERSION_MAX; i++ ) {
/* don't publish version 2 as we don't really support it
* (even when configured to accept version 2 Bind requests)
* and the value would never be used by true LDAPv2 (or LDAPv3)
* clients.
*/
for ( i=LDAP_VERSION3; i<=LDAP_VERSION_MAX; i++ ) {
char buf[BUFSIZ];
if (!( global_allows & SLAP_ALLOW_BIND_V2 ) &&
( i < LDAP_VERSION3 ) )
{
/* version 2 and lower are disallowed */
continue;
}
snprintf(buf, sizeof buf, "%d", i);
val.bv_val = buf;
val.bv_len = strlen( val.bv_val );
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment